Php5 käyttö ja version vaihtaminen.

Neobitin palvelimet tukevat oletuksena PHP 4.4x ja PHP 5.x ja ovat käytössä rinnan.

Webhotellisi PHP version voit vaihtaa cPanelista kirjautuneena kohdasta "PHP Version Manager"

Valittavissa on PHP versiot 5.2 - 5.5

Vaihtoehtoisesti saat PHP5.x käyttöösi lisäämällä seuraavat rivit .htaccess -tiedostoon kotihakemistossasi /public_html/.htaccess

AddType application/x-httpd-php5 .php
AddHandler application/x-httpd-php5 .php

Mikäli sivustosi ilmoittaa PHP version vaihdoksen jälkeen "Internal server error" on mahdollisesti .htaccess tiedostossa vääriä määrityksiä, voit poistaa tai nimetä tiedoston turvallisesti uudelleen kotihakemistostasi /public_html/.htaccess

Muutoksen jälkeen sivuston toiminta palautuu. Tarvittaessa ota yhteyttä tukeemme sähköpostitse tuki@neobitti.fi tai "Oma Neobitti" tilin kautta: https://secure.neobitti.fi/login.html

Auttoiko tämä artikkeli teitä?

 Tulosta artikkeli

Lue myös

Php register_globals

php5.x Luo kansio: "_custom_php_settings" (ilman lainausmerkkejä) ja lisää siihen php.ini...